0.16升级到0.17 问题汇总


#1
  • Choerodon平台版本: 0.17.0
  1. wiki 空间没了

    后面又自动恢复了。。。
  2. sonarqube 安装升级文档没有说明
    安装文档 有名字冲突
  3. 知识管理上传本地图片失败
  4. 代码质量管理 域名有误
  5. 组织项目实例 找不到
  6. 找不到相关页面

#2

问题3:knowledgebase-service服务也是要配置minio的


#3

配了的


#4

代码质量管理的异常地方,如果平台不需要sonarqube插件,需要去c7n-system命名空间下的找到devops-service的configMap,然后移除application.yaml里面sonarqube地址变量service.sonarqube.url(0.16.0版本之后微服务配置读取的是configMap,目前不会根据application.yaml自动更新,需要手动更新),移除之后,重启下devops-service

如果平台想启用sonarqube插件,使用代码质量功能,首先要搭建sonarqube,然后部署或升级devops-service时候新增3个变量,sonarqube的地址,用户名,密码,
SERVICES.SONARQUBE.URL,
SERVICES.SONARQUBE.USERNAME,
SERVICES.SONARQUBE.PASSWORD


#5

你这些 升级文档都没有说明。。。
还是希望 你们文档 能用心点 ,我先 试下


#7

这样?
helm upgrade devops-service c7n/devops-service
–set env.SERVICE.SONARQUBE.URL=“http://sonarqube.xxx.cn
–set env.SERVICE.SONARQUBE.USERNAME=admin
–set env.SERVICE.SONARQUBE.PASSWORD=xxx
-f <(helm get values devops-service)
–version 0.17.2


#8

–set env.SERVICES.SONARQUBE.URL=“http://sonarqube.xxx.cn
–set env.SERVICES.SONARQUBE.USERNAME=admin
–set env.SERVICES.SONARQUBE.PASSWORD=xxx

是SERVICES


#9

不好意思,这边文档少了个S,测试那边没有测到。我们会尽快修改升级文档。
你这边可以同版本升级,先把这个参数加上SERVICES_ATTACHMENT_URL

helm install c7n/knowledgebase-service \
    --set env.open.SERVICES_ATTACHMENT_URL="http://minio.example.choerodon.io/knowledgebase-service/" \
    -f <(helm get values knowledgebase-service) \
    --version 0.17.2

#10

问题2: --name gitlab-client改为--name sonarqube-client


#11


改了升级后 一直上传中

knowledgebase-service日志


#12


升级了还是不行


#13

看一下浏览器的network请求。


#14

不好意思,上面回复错了,应该是
–set env.open.SERVICES_SONARQUBE_URL=“http://sonarqube.xxx.cn
–set env.open.SERVICES_SONARQUBE_USERNAME=admin
–set env.open.SERVICES_SONARQUBE_PASSWORD=xxx


#15
 helm upgrade devops-service c7n/devops-service     -f <(helm get values devops-service)     --set env.open.SERVICES_SONARQUBE_URL="http://sonarqube.xxx.cn"     --set env.open.SERVICES_SONARQUBE_USERNAME=xxx     --set env.open.SERVICES_SONARQUBE_PASSWORD=xxx     --version 0.17.2

#16

对的


#17

已解决!


#19

5 6 有人跟吗?好几个页面都找不到

消息中心 也全部找不到页面


#20

helm list看下版本


#21


workflow 升级文档里没有说需要升级?
按道理应该是0.17版本 需要升级吧


#22

你重启下mangaer-service